Navegando neste Tópico:   1 usuários anônimos


 Final   Tópico anterior   Próximo tópico  Novo tópico



APT não dá!
Usuário
Cadastrado em:
13/3/2011 22:12
De Montes Claros
Grupo:
Usuário
Mensagens: 139
Nível : 10; EXP : 84
HP : 0 / 246
MP : 46 / 4635
Offline
Nunca gostei do sistema do apt. Infelizmente, uma distro tão bacana como o Pclinuxos resolveu adotá-la. Explico o porquê: quando baixo um arquivo em rpm, se opto por instalar ele sem checagem de dependências, sei o que estou fazendo. Geralmente eu sei que a dependência que ele reclama já está devidamente instalada e funcionando no meu micro. O grande problema delas é no nome do pacote, em geral. Vejam só: instalei aqui um arquivo convertido pelo Alien. Tive que instalá-lo com a opção --nodeps, pois ele acusava a necessidade de um outro programa, já instalado. Pois bem, após a instalação, o programa funcionou sem nenhum problema, sem nenhum risco à instalação original. Mas quando entro no synaptic, aparece a msg. de que existe um pacote quebrado. Para solucioná-lo, a única alternativa é removê-lo. Aí fico sem o meu programa convertido pelo Alien. Blz, né? Isso para mim é burrice. Ou o apt é burro, ou pensa que eu o sou, por não saber o que instalar. Resumo da ópera: ou eu encontro um novo gerenciador, tipo packagekit da vida para gerenciar os pacotes, ou desisto do Pclinuxos. Para mim, é o apt ou eu. Grande abraço e fiquem com Deus.

Enviado em: 27/4/2012 20:53
_________________
Nossa Senhora Rosa Mística, rogai por nós.
Ricardo Mota


Re: APT não dá!
Usuário
Cadastrado em:
19/5/2011 8:23
De São Paulo SP
Grupo:
Usuário
Mensagens: 295
Nível : 16; EXP : 6
HP : 0 / 376
MP : 98 / 6894
Offline
só pq da pacote quebrado vc vai deixar de usar um sistema inteiro deixa como esta ...
tudo esta funcionando 100% ...

Enviado em: 28/4/2012 8:42
_________________
Clique para ver a Imagem original em uma nova janela

Linux Sempre


Re: APT não dá!
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1841
Nível : 35; EXP : 80
HP : 174 / 870
MP : 613 / 16387
Offline
Citando:

Ricardo Rabelo Mota escreveu:
Nunca gostei do sistema do apt. Infelizmente, uma distro tão bacana como o Pclinuxos resolveu adotá-la. Explico o porquê: quando baixo um arquivo em rpm, se opto por instalar ele sem checagem de dependências, sei o que estou fazendo. Geralmente eu sei que a dependência que ele reclama já está devidamente instalada e funcionando no meu micro. O grande problema delas é no nome do pacote, em geral. Vejam só: instalei aqui um arquivo convertido pelo Alien. Tive que instalá-lo com a opção --nodeps, pois ele acusava a necessidade de um outro programa, já instalado. Pois bem, após a instalação, o programa funcionou sem nenhum problema, sem nenhum risco à instalação original. Mas quando entro no synaptic, aparece a msg. de que existe um pacote quebrado. Para solucioná-lo, a única alternativa é removê-lo. Aí fico sem o meu programa convertido pelo Alien. Blz, né? Isso para mim é burrice. Ou o apt é burro, ou pensa que eu o sou, por não saber o que instalar. Resumo da ópera: ou eu encontro um novo gerenciador, tipo packagekit da vida para gerenciar os pacotes, ou desisto do Pclinuxos. Para mim, é o apt ou eu. Grande abraço e fiquem com Deus.


Oi Ricardo,
Pois então, nem tudo é perfeito: Se você fosse usuário do buguntu, estaria sofrendo agora, na atualização do sistema(que no buguntu, nunca funciona legal).
Realmente, nenhum sistema é 100%, é como casamento, nenhuma mulher é 100%, mas você acaba casando com aquela que dá menos problema.
Com sistema operacional é assim também.
Bom, você poderia nos informar qual o programa que você quer, e, eu tentaria empacotar.
Se for o Rekonq, tem dependência do novo KDE 4.8, então...
Mas, não desanime, já conseguimos tanto para o PCLOS, já estou empacotando programas que são bastante procurados pelos usuários e talz.
A coisa toda só tende a melhorar.

Sds


Enviado em: 28/4/2012 10:14
_________________
Clique para ver a Imagem original em uma nova janela

"Deveis ser a mudança que quereis ver no mundo" Ghandi


Re: APT não dá!
Usuário
Cadastrado em:
8/1/2012 14:26
Grupo:
Usuário
Mensagens: 160
Nível : 11; EXP : 70
HP : 0 / 267
MP : 53 / 4398
Offline
Pelo que vi usamos a versão do Synaptic 0.57.2 de 2005 da Conectiva. Distros baseadas em deb já estão 0.75.9, então penso que talvez usando uma versão um pouco mais recente pode solucionar vários problemas.
O APT usamos a versão 0.5.15 enquanto distros baseadas em deb usam 0.8.16.

O que escrevo não é crítica, apenas como sou novo na distro quero entender ela melhor e contribuir com ideias. Gostei muito dela, leve e estável. Quebra aquele paradigma impossível do desktop ter que ser o mais recente possível. Com um KDE estável e programas finais recentes ficou muito bom.
Minha pergunta é: Na questão do APT e Synaptic a distro ficou parada no tempo por não ter quem adapte esses recursos para RPM como a Conectiva fazia ou tem quem trabalha nisso para vermos como caminham as coisas? Talvez pessoas interessadas no Brasil possam contribuir neste particular, existe alguma outra distro RPM que usa APT para nos inspirarmos?

Enviado em: 13/8/2012 7:19


Re: APT não dá!
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1841
Nível : 35; EXP : 80
HP : 174 / 870
MP : 613 / 16387
Offline
Citando:

fraterlinux escreveu:
Pelo que vi usamos a versão do Synaptic 0.57.2 de 2005 da Conectiva. Distros baseadas em deb já estão 0.75.9, então penso que talvez usando uma versão um pouco mais recente pode solucionar vários problemas.
O APT usamos a versão 0.5.15 enquanto distros baseadas em deb usam 0.8.16.

O que escrevo não é crítica, apenas como sou novo na distro quero entender ela melhor e contribuir com ideias. Gostei muito dela, leve e estável. Quebra aquele paradigma impossível do desktop ter que ser o mais recente possível. Com um KDE estável e programas finais recentes ficou muito bom.
Minha pergunta é: Na questão do APT e Synaptic a distro ficou parada no tempo por não ter quem adapte esses recursos para RPM como a Conectiva fazia ou tem quem trabalha nisso para vermos como caminham as coisas? Talvez pessoas interessadas no Brasil possam contribuir neste particular, existe alguma outra distro RPM que usa APT para nos inspirarmos?


Não, nada a ver. Não compare com o APT do Debian.
Usamos o RPM, da Red Hat, Fedora, Suse, Mandriva, Mageia e afins.
Vide: http://en.wikipedia.org/wiki/RPM_Package_Manager

Nosso sistema está no 4.8.1
O RPM da Red Hat está no 4.10.
Então, estamos bem atualizados. Os novos formatos do RPM (versão 10) só vão entrar em produção quando estiverem muito bem debugados.

Sds

Enviado em: 13/8/2012 11:45
_________________
Clique para ver a Imagem original em uma nova janela

"Deveis ser a mudança que quereis ver no mundo" Ghandi


Re: APT não dá!
Usuário
Cadastrado em:
8/1/2012 14:26
Grupo:
Usuário
Mensagens: 160
Nível : 11; EXP : 70
HP : 0 / 267
MP : 53 / 4398
Offline
Eu me referia ao APT como gerenciador de pacotes integrado ao repositório online e o Synaptic como sua GUI. Eu já tinha visto que a versão RPM é atual.
Respondeu minha pergunta com o link, particularmente este sobre APT-RPM que foi justamente o que eu queria saber mais sobre a adaptação do APT para trabalhar com RPM feito por um brasileiro:
http://en.wikipedia.org/wiki/Apt-rpm

Enviado em: 13/8/2012 12:16


Re: APT não dá!
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1841
Nível : 35; EXP : 80
HP : 174 / 870
MP : 613 / 16387
Offline
Citando:

fraterlinux escreveu:
Eu me referia ao APT como gerenciador de pacotes integrado ao repositório online e o Synaptic como sua GUI. Eu já tinha visto que a versão RPM é atual.
Respondeu minha pergunta com o link, particularmente este sobre APT-RPM que foi justamente o que eu queria saber mais sobre a adaptação do APT para trabalhar com RPM feito por um brasileiro:
http://en.wikipedia.org/wiki/Apt-rpm


Sim, mas não usamos a versão Debian do Synaptic, e sim esta aqui: http://www.nongnu.org/synaptic/

Cuja última atualização foi em 2009. Lá consta como 0.62 a versão mais recente, e a nossa 0.57.
Não muito ruim em termos de idade.
Sei sim que o apt-get foi portado pelo Alfredo Kojima, da Conectiva.
Bons tempos do GNU/Linux no Brasil.
Quanto a interfaces para o apt-get, recentemente o Smart voltou aos repos do PCLOS e, o Yum está sendo portado.

Ok ?

Sds

Enviado em: 13/8/2012 12:33
_________________
Clique para ver a Imagem original em uma nova janela

"Deveis ser a mudança que quereis ver no mundo" Ghandi


Re: APT não dá!
Usuário
Cadastrado em:
8/1/2012 14:26
Grupo:
Usuário
Mensagens: 160
Nível : 11; EXP : 70
HP : 0 / 267
MP : 53 / 4398
Offline
O que me induziu a erro de pensar que se tratava de versão obsoleta é o Help:About do Synaptic que mostra a licença Conectiva S/A 2001-2004 na imagem abaixo:
http://img198.imageshack.us/img198/3812/synapticw.png

Já entendi e estou mais ciente do funcionamento da distro agora. No meu modesto desk está funcionando muito bem e consumindo poucos recursos. Sendo rolling-release eu conseguirei atualizando pelo menos uma vez por mês manter ele leve até quando? De quanto em quanto tempo mudam a versão do KDE que é o que deixa o sistema mais pesado e consumindo memória?

Fantástica a adição de mais opções de gerenciadores de pacotes como yum. O packagekit é uma opção interessante também por se integrar bem a KDE ou Gnome. Existe algum motivo especial para não ter este pacote?

Enviado em: 13/8/2012 12:51


Re: APT não dá!
Usuário
Cadastrado em:
19/5/2011 8:23
De São Paulo SP
Grupo:
Usuário
Mensagens: 295
Nível : 16; EXP : 6
HP : 0 / 376
MP : 98 / 6894
Offline
vc usa linux quanto tempo?

Enviado em: 13/8/2012 13:32
_________________
Clique para ver a Imagem original em uma nova janela

Linux Sempre


Re: APT não dá!
Usuário
Cadastrado em:
8/1/2012 14:26
Grupo:
Usuário
Mensagens: 160
Nível : 11; EXP : 70
HP : 0 / 267
MP : 53 / 4398
Offline
Uns 10 anos, mas como usuário doméstico. Não sou programador nem técnico.
E você?

Enviado em: 13/8/2012 14:22


Re: APT não dá!
Usuário
Cadastrado em:
8/1/2012 14:26
Grupo:
Usuário
Mensagens: 160
Nível : 11; EXP : 70
HP : 0 / 267
MP : 53 / 4398
Offline
Ricardo Rabelo Mota,

Estou testando o SMART e ele é similar ao URPMI, ou seja, se você sabe o que está fazendo, mesmo se tiver dependência quebrada ou conflito ele não impede você de atualizar o sistema ou instalar novos pacotes. Depois de instalado o SMART para saber as opções basta usar # smart --help ou se preferir modo gráfico # smart --gui

Enviado em: 13/8/2012 15:43



 Topo   Tópico anterior   Próximo tópico

 Novo tópico


Você pode exibir os tópicos.
Você pode iniciar um novo tópico.
Você não pode responder.
Você não pode editar.
Você não pode excluir mensagens.
Você não pode incluir votações.
Você não pode votar.
Você não pode anexar arquivos.
Você não pode enviar mensagens sem aprovação.

[Busca Avançada]