Navegando neste Tópico:   1 usuários anônimos


 Final   Tópico anterior   Próximo tópico  Novo tópico



wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Boa noite a todos,

Bem srs, eu gosto sempre de instalar um pacote que faça mudança automatizada dos wallpapers, pesquisei e verifiquei que o Wallpapoz, está em nossos repos.
Fui ao Synapic e baixei nosso amigo, mas....problemas:

1_Ele não colocou uma entrada automatizada (como era de se esperar)em Menus

2_Só consigo vê-lo usando terminal fazendo
$ wallpapoz

3_Fiz isso e configurei nosso pacote com meus walls

3.1_Cliquei em restart dentro de configurações e não percebi mudança alguma

4_Coloquei nosso pacote em Menu..Mais aplicativos..Configuração..LXAutostart

5_Restartei o PC, mas a única coisa que acontece é aparecer novamente a telinha do wallpapoz, nada do pacote funcionar na troca de walls

Alguém poderia me ajudar??

No aguardo

Valeu!

Enviado em: 5/9/2012 23:12
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Boa noite a todos,

Continuando ae a saga prá fazer o wallpapoz funfar, dei uma googlada e me veio isso:

http://www.mandrivabrasil.org/site/fo ... ex.php?topic=11583.0;wap2

Em linhas gerais, o texto ensina como trocar o pcmanfm pelo nautilus, fiz isso porque li pela ae, que, o pcmanfm não consegue elaborar bem o wallpapoz.

Resumo do que manda o texto:

1_Editar o arquivo...>/etc/xdg/lxsession/LXDE/autostart

2_Comentar a linha:
@pcmanfm -d

3_Depois adicione:
@dbus-launch --exit-with-session nautilus -n

4_Salve o arquivo e feche

5_Feche a sessão e voce terá o nautilus

Mas mesmo assim, o wallpapoz continua se negando a funfar, tá faltando algum "pulo do gato"

No aguardo!!

Enviado em: 6/9/2012 23:59
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
13/3/2011 22:12
De Montes Claros
Grupo:
Usuário
Mensagens: 139
Nível : 10; EXP : 84
HP : 0 / 246
MP : 46 / 4745
Offline
Não conheço o aplicativo, e não tenho o LXDE aqui. Mas e se você colocar uma entrada para o wallpapoz no ~/.config/autostart? Será que, iniciando juntamente com o WM, ele não irá funcionar? Boa sorte e fique com Deus.

Enviado em: 7/9/2012 17:33
_________________
Nossa Senhora Rosa Mística, rogai por nós.
Ricardo Mota


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Boa noite a todos,

Ok Ricardo, isso já foi feito, dê uma lida no meu 1º post

Citação:


4_Coloquei nosso pacote em Menu..Mais aplicativos..Configuração..LXAutostart

5_Restartei o PC, mas a única coisa que acontece é aparecer novamente a telinha do wallpapoz, nada do pacote funcionar na troca de walls


No aguardo!!

Enviado em: 7/9/2012 18:27
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Visitante
Olá Rweu,

Veja se essa dica acho que do mesmo André do Mageia Br não seria seu caso Rotação automática de wallpapers no LXDE

Espero que lhe auxilie.

T+

Enviado em: 8/9/2012 12:49


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Boa noite a todos,

hahahah, ok Cretão....meu caso seria fazer o wallpapoz funfar no LXDE/Pacmafm, mas se não tiver jeito mesmo....

Vou dar uma olhada nesse script e ver se funfa por aqui... daqui a pouco eu te digo se tá legal...


Valeu!!

Enviado em: 8/9/2012 20:32
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
OK vejamos

1_Criei o arquivo igual ao texto da dica, dentro da minha pasta pessoal

# nano /home/rweu wallpaper-rotate.sh

#!/bin/bash
 
# Pasta onde têm os vossos wallpapers
DIR=/home/rweu/Wallpapers/
FLOOR=1
RANGE
=`ls -1 "$DIR"/*.{png,jpg} | wc -l`
 
number=$RANDOM
while [ "$number-le $FLOOR ]; do
        
number=$RANDOM
done
let 
"number %= $RANGE"  # Escolher um dos wallpapers
COUNTER=1
for X in "$DIR"/*.{png,jpg}
do
if [ $number -eq $COUNTER ]; then
 pcmanfm --set-wallpaper "$X"
fi
COUNTER=$(($COUNTER+1))
done
COUNTER=1


2_Tornei-o executável com o chmod u+x

3_Por último eu abri um cron na minha pasta

$ nano crontab -e

*/* * * * export DISPLAY=:; /home/andre/wallpaper-rotate.sh


...esse ae é prá teste de minuto em minuto.

O problema aqui é que, se eu executo o arquivo wallpaper-rotate.sh na "mão grande" clicando nele, ele realmente muda o wallpaper, mas a automação via o cron não está atuando

No aguardo.

Obs: Primeiro eu tive o cuidado de reeditar o arquivo onde eu havia colocado o nautilus no lugar do PacmanFm, ou seja tô usando o PacmanFM de novo, que é o gerenciador aplicado a essa solução de script.


Enviado em: 8/9/2012 23:07
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Visitante
Olá Rweu

Estou na Bahia - Feira de Santana a trabalho (trouxe caranguejos de são caetano de odivelas, famosos viu) e espero que na terça já esteja de volta ao aconchego do lar e nem que seja nas pesquisas espero poder ajudar.

Já que não uso o LXDE.

T+

Enviado em: 9/9/2012 9:36


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Bom dia a todos,

OK srs, no próprio link da dica do Creto, também há um link, que apesar de dizer "script existente dos fóruns do LXDE", na realidade nos remete ao fórum internacional do PCLOS

...> http://www.pclinuxos.com/forum/index.php?topic=87784.0

essa dica contém como fazer a parada sem usar o CRON/CRONTAB

#!/bin/bash

DIR=/home/rweu/Wallpapers/
FLOOR=1
RANGE
=`ls -1 "$DIR"/*.jpg | wc | awk '// {print $1}'`

number=0

while [ -eq 1 ]; do
   
   
number=$RANDOM
   
while [ "$number-le $FLOOR ]; do
        
number=$RANDOM
   done
   let 
"number %= $RANGE"  # Scales $number down within $RANGE.
   
COUNTER=1
   
for X in "$DIR"/*.jpg
   do
      if [ $number -eq $COUNTER ]; then
         pcmanfm --set-wallpaper "$X"
      fi
   COUNTER=$(($COUNTER+1))
   done
   COUNTER=1
   sleep 10m
done


essa tá funfando de boa, bastou criar o arquivo, etc e saiu funfando..agora tô aqui verificando como fazer prá ele se startar ao rebootar o S.O.!!!!


Voltei, para startar no boot basta fazer:

1_Icone "Configure your LXDesktop"
2_Personal
3_Autostart Settings
4_Advanced
5_Vai aparecer um Script do LX-Autostart
6_Clicar em editar
7_Sapeque o script
8_Ok


Valeu!!

Enviado em: 9/9/2012 10:13

Editado por RWagner em 09-09-2012 10:32:07
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Visitante
Rweu, como vê por isso não postei o link principal pois mesmo entrando em contato com o pessoal lá old polack ele me pediu meu nick no forum como se não tenho e lá sou dado como spam, isso é outra conversa.

Fico feliz por você e olha, bem que o mestre ai poderia acrescentar isso na wiki hein depois de prontão para uso???

T+

Enviado em: 9/9/2012 11:57


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Boa noite a todos,


Ok Creto, boa pedida!, vou dar uma olhada em algum que já esteja pronto, e tal como fiz no Mint, ....> http://www.linuxmint.com.br/forum/t-1 ... t_id=10467#forumpost10467 vou tentar elaborar um how to de como proceder (se bem que eu acho que isso já deveria ser praxe em qq Distro que se preze).

Isso, aqui como lá, tenho certeza vai impulsionar a rapazi a produzir conteúdo.
Antes, tenho de dar uma estudada, verificando se os comandos são iguais aos de lá, mas isso é "galho fraco"!

Inté!!

OBS: Quem se dispuser, e quiser se antecipar ae com os comandinhos da wiki, fique a vontade para postá-los ok!!??

Enviado em: 9/9/2012 19:33
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Boa noite a todos,

Tá lá o corpo extendido no chão!!

...> http://www.pclinuxosbrasil.com.br/mod ... 0&mode=0&type=0&order=ASC

Enviado em: 10/9/2012 19:19
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Visitante
Citando:

RWagner escreveu:

Tá lá o corpo extendido no chão!!


Conheço essa letra ai, não sabia que gostava de rap, hehehe.

Brazuca é bom de bola..., Zé batalha só...

Resolvido?

T+

Enviado em: 15/9/2012 17:29


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
6/5/2011 22:01
De Rio - RJ
Grupo:
Usuário
Mensagens: 153
Nível : 11; EXP : 42
HP : 0 / 260
MP : 51 / 4915
Offline
Boa noite a todos,


hahahahahha...nem sabia dessa de Rap, sempre falei isso como a dizer, "isso é real"..."a coisa fluiu"..."taqui a prova"...etc...etc...

Mas em relação ao Walpapoz não ficou resolvido não!, ele não quiz funfar, já em relação a mudança automatizada de fundo de tela sim, com a dica que voce me passou!! e foi em cima disso que criei o how to, lá na Wiki!!

Valeu!

Enviado em: 15/9/2012 20:50
_________________
Clique para ver a Imagem original em uma nova janela
RWagner-LXDE
Visite o: blog

Registered user # 476274

"Quem come prego...,sabe o dia de amanhã!


Re: wallpapoz não quer funfar!!
Visitante
Beleza RWagner, é que as vezes confundo os parafusos.

T+

Enviado em: 17/9/2012 20:45


Re: wallpapoz não quer funfar!!
Usuário
Cadastrado em:
19/5/2011 8:23
De São Paulo SP
Grupo:
Usuário
Mensagens: 295
Nível : 16; EXP : 6
HP : 0 / 376
MP : 98 / 7065
Offline
Eu fiz uma variação do script só assim funciono sem nem um pau .

no PCLinuxOS autostart pode ser em outro lugar e pode ter outro nome eu estou em um Debian.

editar arquivo
leafpad /etc/xdg/lxsession/LXDE/autostart

no inicio do arquivo coloque essas linhas

@killall ola-desktop
@killall sleep

essas linhas serve para não rodar mais de uma vez o mesmo
script caso vc reinicie o X

no fim do arquivo coloque essa linha .
E para executar o arquivo com os comandos
@/usr/imagens/ola-desktop

EX:meu arquivo /etc/xdg/lxsession/LXDE/autostart

@killall ola-desktop
@killall sleep
@xrandr -s 1280x960 --rate 60
@lxpanel --profile LXDE
@pcmanfm --desktop --profile LXDE
@xscreensaver -no-splash
@setxkbmap -option terminate:ctrl_alt_bksp
# servidor remoto
#@/usr/lib/vino/vino-server
#openbox --replace executar script print
openbox --replace
@/usr/imagens/ola-desktop

crie uma pasta , EX:mkdir /usr/imagens
de as permissão de execução, EX:chmod 777 /usr/imagens
Coloque as imagens na pasta mais não como root
recomendado minimo de 4 imagens .

crie um arquivo para ser executado com o nome ola-desktop na pasta , EX:leafpad /usr/imagens/ola-desktop

#!/bin/bash

while true
do
sleep 30m
# Pasta onde têm as imagens
DIR=/usr/imagens
FLOOR=1
RANGE=`ls -1 "$DIR"/*.jpg | wc | awk '// {print $1}'`

number=$RANDOM
while [ "$number" -le $FLOOR ]; do
number=$RANDOM
done
let "number %= $RANGE"
COUNTER=1
for X in "$DIR"/*.jpg
do
if [ $number -eq $COUNTER ]; then
pcmanfm --set-wallpaper "$X"
fi
COUNTER=$(($COUNTER+1))
done
COUNTER=1
done


OBS: (sleep 30m) e o tempo de troca das imagens. 30 minutos

de as permissão de execução, EX:chmod 777 /usr/imagens/ola-desktop

só reiniciar o pc fim




Enviado em: 24/11/2012 9:45

Editado por fran em 24-11-2012 10:24:46
Editado por fran em 24-11-2012 10:33:13
Editado por fran em 24-11-2012 10:43:43
_________________
Clique para ver a Imagem original em uma nova janela

Linux Sempre



 Topo   Tópico anterior   Próximo tópico

 Novo tópico


Você pode exibir os tópicos.
Você pode iniciar um novo tópico.
Você não pode responder.
Você não pode editar.
Você não pode excluir mensagens.
Você não pode incluir votações.
Você não pode votar.
Você não pode anexar arquivos.
Você não pode enviar mensagens sem aprovação.

[Busca Avançada]