Navegando neste Tópico:   1 usuários anônimos


 Final   Tópico anterior   Próximo tópico  Novo tópico



rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
8/4/2011 22:47
De Aracaju, capital de Sergipe
Grupo:
Usuário
Administrador
Mensagens: 327
Nível : 16; EXP : 89
HP : 0 / 397
MP : 109 / 7755
Offline
Estou tentando instalar uns pacotes via terminal e o sistema aponta erro relativo a essa dependência. O problema é que ela não consta nos repositórios e, pesquisando na internet, achei muita coisa sobre, mas não achei a própria para download.

Eis um trecho da falha apontada:
yelp 3.0.2 is needed by yelp-lang-3.0.2-1.2.noarch
rpmlib
(PayloadIsLzma) <= 4.4.6-1 is needed by yelp-lang-3.0.2-1.2.noarch
rpmlib
(PayloadIsLzma) <= 4.4.6-1 is needed by yelp-xsl-3.0.1-1.1.noarch
rpmlib
(PayloadIsLzma) <= 4.4.6-1 is needed by yelp-xsl-lang-3.0.1-1.1.noarch

zenity 
3.0.0 is needed by zenity-lang-3.0.0-1.2.noarch
rpmlib
(PayloadIsLzma) <= 4.4.6-1 is needed by zenity-lang-3.0.0-1.2.noarch

rpm 
4.4.6-18pclos2007 is needed by (installedrpm-build-4.4.6-18pclos2007.i586

Enviado em: 2/5/2011 16:44
_________________
:: Acima de tudo, Deus! ::
É usuário novo? Clique aqui: Recomendações aos novos usuários


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1873
Nível : 36; EXP : 4
HP : 175 / 876
MP : 624 / 17278
Offline
Ahh, a famosa rpmlib(PayloadIsLzma). Essa lib não é uma LIB, é uma capacidade da LIB RPM lib nessa versão.

Digite rpm --showrc | more

E você verá quais são as capacidades da LIB RPM.
rpmlib(PayloadIsLzma) significa que o programa usa uma capacidade da lib RPM, que é compactação LZMA.
Ok ???

Faça o comando e poste o resultado para a gente poder analisar.

Sucesso!

Enviado em: 2/5/2011 19:35


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
8/4/2011 22:47
De Aracaju, capital de Sergipe
Grupo:
Usuário
Administrador
Mensagens: 327
Nível : 16; EXP : 89
HP : 0 / 397
MP : 109 / 7755
Offline
Citando:

Digite rpm --showrc | more

Faça o comando e poste o resultado para a gente poder analisar.


[marcelo@localhost ~]$ rpm --showrc more
ARCHITECTURE 
AND OS:
build arch            i586
compatible build archs
i686 i586 i486 i386 noarch fat
build os              
Linux
compatible build os
's : Linux
install arch          : i686
install os            : Linux
compatible archs      : i686 i586 i486 i386 noarch fat
compatible os'
s       Linux

RPMRC VALUES
:
macrofiles            : /usr/lib/rpm/macros:/usr/lib/rpm/i686-linux/macros:/usr/
lib/rpm/mandriva/macros:/usr/lib/rpm/mandriva/i686-linux/macros:/etc/rpm/macros:
/
etc/rpm/i686-linux/macros:/etc/rpm/macros.cdb:/etc/rpm/macros.d/*.macros:~/.rpm
macros
optflags              : %{__common_cflags} -fomit-frame-pointer -march=i686 -fas
ynchronous-unwind-tables

Features provided by rpmlib installer:
    rpmlib(BuiltinLuaScripts) = 4.2.2-1
    rpmlib(CompressedFileNames) = 3.0.4-1
    rpmlib(ConcurrentAccess) = 4.1-1
    rpmlib(ExplicitPackageProvide) = 4.0-1


Mas, dando "Enter", aparecem muitos outros dados. Como o conteúdo é extenso, preferi copiar em um editor e colocar em anexo.

Anexar arquivo:


zip Resultado rpm --showrc | more.zip Tamanho: 15.78 KB; Acessos: 367

Enviado em: 2/5/2011 19:54
_________________
:: Acima de tudo, Deus! ::
É usuário novo? Clique aqui: Recomendações aos novos usuários


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1873
Nível : 36; EXP : 4
HP : 175 / 876
MP : 624 / 17278
Offline
O que interessa é isso aqui:

Features provided by rpmlib installer:
rpmlib(BuiltinLuaScripts) = 4.2.2-1
rpmlib(CompressedFileNames) = 3.0.4-1
rpmlib(ConcurrentAccess) = 4.1-1
rpmlib(ExplicitPackageProvide) = 4.0-1
rpmlib(HeaderLoadSortsTags) = 4.0.1-1
rpmlib(HeaderTagTypeInt64) = 4.4.3-1
rpmlib(PartialHardlinkSets) = 4.0.4-1
rpmlib(PayloadFilesHavePrefix) = 4.0-1
rpmlib(PayloadIsBzip2) = 3.0.5-1
rpmlib(PayloadIsUstar) = 4.4.4-1
rpmlib(ScriptletInterpreterArgs) = 4.0.3-1
rpmlib(VersionedDependencies) = 3.0.3-1

Supondo que você esteja usando o mesmo PCLOS que eu 2010.12, a rpmlib atual do PCLOS não suporta compactação LZMA.

Suporta a compactação Bzip2, mas não a LZMA.

Enviado em: 2/5/2011 19:59


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
8/4/2011 22:47
De Aracaju, capital de Sergipe
Grupo:
Usuário
Administrador
Mensagens: 327
Nível : 16; EXP : 89
HP : 0 / 397
MP : 109 / 7755
Offline
Citando:

AgentSmith escreveu:
Supondo que você esteja usando o mesmo PCLOS que eu 2010.12, a rpmlib atual do PCLOS não suporta compactação LZMA.

Suporta a compactação Bzip2, mas não a LZMA.
2010.10 Gnome.
Danou-se... Então não vou poder instalar os pacotes? Será que não há algum jeito? Vamos às pesquisas!

Obrigado pelos esclarecimentos.

Fique com Deus.

Enviado em: 2/5/2011 22:28
_________________
:: Acima de tudo, Deus! ::
É usuário novo? Clique aqui: Recomendações aos novos usuários


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1873
Nível : 36; EXP : 4
HP : 175 / 876
MP : 624 / 17278
Offline
Na verdade, o que você está querendo instalar ? E, como você está tentando instalar ?

Enviado em: 3/5/2011 1:10


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
8/4/2011 22:47
De Aracaju, capital de Sergipe
Grupo:
Usuário
Administrador
Mensagens: 327
Nível : 16; EXP : 89
HP : 0 / 397
MP : 109 / 7755
Offline
Citando:

AgentSmith escreveu:
Na verdade, o que você está querendo instalar ? E, como você está tentando instalar ?
Pacotes para a tentativa de instalação do Gnome 3.0. Baixei os pacotes daqui e tentei instalá-los pelo rpm -Uvh *.rpm.

Fique com Deus.

Enviado em: 3/5/2011 14:19
_________________
:: Acima de tudo, Deus! ::
É usuário novo? Clique aqui: Recomendações aos novos usuários


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1873
Nível : 36; EXP : 4
HP : 175 / 876
MP : 624 / 17278
Offline
Ahh, do Open Suse, não vai rolar. A árvore deles é diferente da do PCLOS. Nem o Mandriva e nem o RH vai funfar também.
Uma coisa que funciona é pegar o Debian i386 e converter com o ALIEN. Geralmente funciona.
Dá uma experimentada(mas, numa máquina de testes) e vê se funciona.

Sds

Enviado em: 3/5/2011 15:38


Re: rpmlib(PayloadIsLzma): onde acho isso?
Usuário
Cadastrado em:
8/1/2012 14:26
Grupo:
Usuário
Mensagens: 160
Nível : 11; EXP : 70
HP : 0 / 267
MP : 53 / 4634
Offline
AgentSmith,

Boa dica, assim vou dar preferência por alienar um pacote quando não funcionar instalar de outra distro. Agora, por que vocês sempre indicam o rpm que não instala automaticamente as dependência, se o apt-get instala o pacote e as dependências automaticamente?

Enviado em: 12/8/2012 23:53
_________________
"Seja a mudança que você quer ver no mundo"


Re: rpmlib(PayloadIsLzma): onde acho isso?
Administração
Cadastrado em:
14/3/2011 8:53
Grupo:
Administrador
Mensagens: 1873
Nível : 36; EXP : 4
HP : 175 / 876
MP : 624 / 17278
Offline
Citando:

fraterlinux escreveu:
AgentSmith,

Boa dica, assim vou dar preferência por alienar um pacote quando não funcionar instalar de outra distro. Agora, por que vocês sempre indicam o rpm que não instala automaticamente as dependência, se o apt-get instala o pacote e as dependências automaticamente?


Porque essa instalação é de pacotes isolados.
O RPM argumento nome do arquivo é local.
O APT-GET funciona para os repos (até onde eu saiba)
É perigoso usar o apt-get com dependências fora dos repositórios.
Pode acarretar a instalação de algum pacote que danifique a instalação do usuário.
Os pacotes indicados, ou estão no testing, ou são de fonte confiável que não irão danificar o sistema.

Sds

Enviado em: 13/8/2012 11:59
_________________
Clique para ver a Imagem original em uma nova janela

"Deveis ser a mudança que quereis ver no mundo" Ghandi


Re: rpmlib(PayloadIsLzma): onde acho isso?
Usuário
Cadastrado em:
8/1/2012 14:26
Grupo:
Usuário
Mensagens: 160
Nível : 11; EXP : 70
HP : 0 / 267
MP : 53 / 4634
Offline
Bem lembrado de alertar para essa questão. Em qualquer distro ao instalar pacotes não oficiais pode-se quebrar a distro. Aqueles que estivem conscientes dos riscos eu notei que o APT no PCLOS tem um funcionamento similar ao URPMI que basta indicar o arquivo local que se tiver as dependências no repositório ele vai instalar o pacote e satisfazer suas dependências.
Um ponto que alguns não gostam mas garantem ter menos problemas, se instalar um pacote com dependências quebradas o APT te força a desinstalar, senão não instala mais nada.

Enviado em: 13/8/2012 12:23



 Topo   Tópico anterior   Próximo tópico

 Novo tópico


Você pode exibir os tópicos.
Você pode iniciar um novo tópico.
Você não pode responder.
Você não pode editar.
Você não pode excluir mensagens.
Você não pode incluir votações.
Você não pode votar.
Você não pode anexar arquivos.
Você não pode enviar mensagens sem aprovação.

[Busca Avançada]